The parts for my latest home PC arrived yesterday afternoon and Gabe and I spent a couple hours assembling them into a workable system. It’s amazing how much help a 4-year-old can provide, even around delicate PC parts. I now have a working Athlon 64 3000+ (S939) system with 1 GB of ram and a reasonably large amount of disk space sitting on my desk. I’m going to be using this for Xen testing, but I’ll write more about that later. For now, I want to concentrate on the hardware.

I went out on a limb a bit when ordering this system, because the motherboard I picked, MSI’s RS480M2-IL, is the first motherboard on the market with ATI’s first Athlon 64 chipset (the Radeon Xpress 200), and Google doesn’t give any clear Linux success stories for the motherboard or chipset. However, this is the only socket 939 board that I could find with on-board video, and I really like on-board video for servers. It was also quite a bit cheaper then buying a comparable board plus an AGP video card. A bit of poking around suggested that the SATA ports might be trouble, and it was unclear how well X supports the on-board video, but I don’t really care about either of those for this system. The parallel IDE ports and Ethernet are the only really important parts for me.

So, after installing all of the hardware, I burned a new Ubuntu install CD and gave it a spin. It booted up okay, found the network, found the IDE hard drives, and installed without any serious problems. Ubuntu’s install CD doesn’t seem to have a driver for ATI’s IDE chipset, so I was stuck in slow PIO mode, but it still worked. Once the install finished, I rebooted and watched Ubuntu try to add all of Gnome and OpenOffice to my nice little server system–yikes. After stopping that, I installed gcc, downloaded the source for Linux 2.6.11.4, and build a new kernel.

After booting the new kernel, almost everything looks okay. Here are the drivers needed for this hardware:

  • IDE: ATI IXP (in stock 2.6.11)
  • SATA: libata’s sata_sil driver detects 4 SATA ports. I have no SATA drives to use for testing, though.
  • Ethernet: 8193too (in stock 2.6.11)
  • IEEE1394/firewire: OHCI1394 (in stock 2.6.11). Only lightly tested, but able to mount disks connected to FW DVD burner.
  • USB: EHCI (8 ports USB 2.0)/OHCI (4 ports USB 1.1). Looks okay, but untested.

I’m currently fighting two problems: 1. Massive clock skew–the system clock is running twice as fast as it should. This is usually a power-management issue or a BIOS bug. A lot of new systems suffer from this, and it shouldn’t take too long to fix. 2. The system won’t reboot cleanly. Linux shuts down okay, but the system hangs and I need to hit ‘reset’ before it’ll reboot. This is probably related to problem #1.

Update (3/18/2005): Disabling the APIC fixed the clock problem, but not the reboot problem. I tried changing a number of power management settings without success. Most likely, the APIC will start working with a future BIOS revision. This problem seems to be preventing me from booting Xen right now, but that’ll probably be fixed by a new version of Xen in the fairly short term.